Problem Fixed

djbigdad
Posts: 2
Joined: 02 Oct 2014, 16:28

Problem Fixed

Postby djbigdad » 02 Oct 2014, 16:38

Problem Fixed
Last edited by djbigdad on 28 Oct 2014, 22:02, edited 1 time in total.

MooCowMusic
Site Admin
Posts: 204
Joined: 04 Jun 2013, 11:27

Re: Pianist Pro Vs. LOCALHOST Please Help

Postby MooCowMusic » 09 Oct 2014, 09:43

Sorry you are having problems.
Not totally sure what the issue is there. Presumably you are using Network MIDI? In which case all the networking side is taken care of by OSX/iOS and Pianist Pro merely asks iOS to create a connection. I don't see how the port used by Network MIDI would conflict with standard web ports. And you say that you disable all the web server applications and Network MIDI is still giving you problems? Which sounds to me that there may be something else that is going on.
Also you have your DAW running, and although I can't think of a reason (non-intentional pun) why Reason would have trouble, I do not own that specific DAW to test with.
What I'd do first of all is to disable / close all these apps and just run MIDI Monitor and then connect to Pianist Pro via Audio MIDI Setup. If you see the correct MIDI messages appearing in MIDI Monitor then that proves the Pianist Pro--Network MIDI connection, and you know that it's the path from there to your DAW that has issues.
Also, one last (stupid) question: have you checked that you only have MIDI OUT set in Pianist Pro and not MIDI IN also, since some DAWs seem to echo incoming MIDI back out again, and Pianist Pro can also do that, causing MIDI feedback.

djbigdad
Posts: 2
Joined: 02 Oct 2014, 16:28

Re: Fixed Problem

Postby djbigdad » 28 Oct 2014, 21:51

I was able to fix the problem with something simple you said. I turned "midi in" signal setting to none; instead of network. I kinda feel stupid but just glad I learned more about MIDI Troubleshooting. This problem occurred around the same time I set up a localhost server on my mac book pro. In the past I haven't had any issues with leaving the "midi in" signal also connected to the network. It makes sense that it would make an infinite loop. I literally went threw all potential ideas; (ports, closing other apps, closing other apps on mac) before finding this setting fixed it! I appreciate you having me look at that setting because it was something I never ran into before. While I'm here Id like to say Thanks for such a great app and I would love to be more involved with the Moocow music community! Ive build over 250 tracks with Pianist Pro and love it to dead! The midi function is the basic feature I use it for but it seems to do exactly what I want and works right most of the time! lol

Thanks again for the quick response/support!
(you can remove this post...)


Return to “Support”